ecoQ DryAir 30L Essential – Device Not Working

Modified on Mon, 12 Jan at 12:53 AM

Question

Why is the device not working?


Answer


Possible causes:

  • No power supply

  • Water full indicator is flashing

  • Room temperature is below 5 °C or above 35 °C


Solutions:

  • Connect the device to a working power outlet and switch it on.

  • Empty the water tank and reinsert it properly, or make sure the tank is correctly positioned.

  • Self-protection mode: The device cannot operate at these temperatures.



Do you have any other questions that we have not yet been able to answer? No problem – our advisory team will be glad to assist you: contact ecofort.

Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us know how can we improve this article!

Select at least one of the reasons
CAPTCHA verification is required.

Feedback sent

We appreciate your effort and will try to fix the article